Exception has been thrown by the target of an invocation

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Has anyone else ever seen this? Seems to appear only when exporting to PDF. So I'm thinking that maybe its related to the appdomain error that I've seen referenced on here. Restarting ASPNET resolved it.

    ——Excerpt of stack trace below——
    Exception has been thrown by the target of an invocation.
    at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean verifyAccess)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at C1.Win.C1Report.2.1D()
    at C1.Win.C1Report.Layout.9Q()
    at C1.Win.C1Report.C1Report.B4()
    at C1.Win.C1Report.C1Report.B3(0 07K)
    at C1.Win.C1Report.C1Report.RenderToFile(String fileName, FileFormatEnum fmt)
    at C1.Web.C1WebReport.X.4O(Boolean RI)
    at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    at

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo, switching to 1.1 is a major undertaking for those of us in production development. It requires us to switch to VS 2003 and upgrade all of our components. It is absolutely essential that Component One get ShowPDF() working in the 1.0 environment. Crystal seems to have done it!

    "Bernardo de Castilho" wrote:
    >Hi Michael.
    >
    >It does seem related to the appdomain problem.
    >
    >If you don't want to use the workaround (restarting aspnet_wp.exe), then the
    >solution would be for you to switch to .NET 1.1 (where they fixed that bug)
    >and wait for the 1.1 build of the component (we're testing it now, let me
    >know if you would like a copy to test yourself).
    >
    >
    >
    >
    >"Michael" wrote in message
    >news:3ef49334$1@news.componentone.com…
    >>
    >> Has anyone else ever seen this? Seems to appear only when exporting to
    >PDF. So I'm thinking that maybe its related to the appdomain error that
    >I've seen referenced on here. Restarting ASPNET resolved it.
    >>
    >> ——Excerpt of stack trace below——
    >> Exception has been thrown by the target of an invocation.
    >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >culture, Boolean verifyAccess)
    >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags
    >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    >> at C1.Win.C1Report.2.1D()
    >> at C1.Win.C1Report.Layout.9Q()
    >> at C1.Win.C1Report.C1Report.B4()
    >> at C1.Win.C1Report.C1Report.B3(0 07K)
    >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    >FileFormatEnum fmt)
    >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    >> at
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    It does work.

    The problem occurs if you make changes to the app, then rebuild it without
    restarting asnet_wp.exe.

    We have published a simple workaround that takes care of the problem, just
    add the following code to the global.asax.cs file:

    protected void Application_End(Object sender, EventArgs e)
    {
    // End aspnet_wp process to avoid possible UnloadedAppDomain
    // error while developing apps (aspnet_wp will restart
    automatically).
    //
    Environment.Exit(0);
    }

    This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    workaround).

    We will eventually have a pdf filter written in managed code, and that will
    allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter is
    not ready yet (should take a few weeks still).

    "Lee Mellinger" wrote in message
    news:3ef74e0f$1@news.componentone.com…
    >
    > Bernardo, switching to 1.1 is a major undertaking for those of us in
    production development. It requires us to switch to VS 2003 and upgrade all
    of our components. It is absolutely essential that Component One get
    ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    >
    > "Bernardo de Castilho" wrote:
    > >Hi Michael.
    > >
    > >It does seem related to the appdomain problem.
    > >
    > >If you don't want to use the workaround (restarting aspnet_wp.exe), then
    the
    > >solution would be for you to switch to .NET 1.1 (where they fixed that
    bug)
    > >and wait for the 1.1 build of the component (we're testing it now, let me
    > >know if you would like a copy to test yourself).
    > >
    > >
    > >
    > >
    > >"Michael" wrote in message
    > >news:3ef49334$1@news.componentone.com…
    > >>
    > >> Has anyone else ever seen this? Seems to appear only when exporting to
    > >PDF. So I'm thinking that maybe its related to the appdomain error that
    > >I've seen referenced on here. Restarting ASPNET resolved it.
    > >>
    > >> ——Excerpt of stack trace below——
    > >> Exception has been thrown by the target of an invocation.
    > >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    > >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    > >culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    > >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    > >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    > >culture, Boolean verifyAccess)
    > >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    BindingFlags
    > >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    > >> at C1.Win.C1Report.2.1D()
    > >> at C1.Win.C1Report.Layout.9Q()
    > >> at C1.Win.C1Report.C1Report.B4()
    > >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > >FileFormatEnum fmt)
    > >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > >> at
    > >
    > >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Hi Michael.

    It does seem related to the appdomain problem.

    If you don't want to use the workaround (restarting aspnet_wp.exe), then the
    solution would be for you to switch to .NET 1.1 (where they fixed that bug)
    and wait for the 1.1 build of the component (we're testing it now, let me
    know if you would like a copy to test yourself).

    "Michael" wrote in message
    news:3ef49334$1@news.componentone.com…
    >
    > Has anyone else ever seen this? Seems to appear only when exporting to
    PDF. So I'm thinking that maybe its related to the appdomain error that
    I've seen referenced on here. Restarting ASPNET resolved it.
    >
    > ——Excerpt of stack trace below——
    > Exception has been thrown by the target of an invocation.
    > at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    > at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    culture, Boolean verifyAccess)
    > at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags
    invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    > at C1.Win.C1Report.2.1D()
    > at C1.Win.C1Report.Layout.9Q()
    > at C1.Win.C1Report.C1Report.B4()
    > at C1.Win.C1Report.C1Report.B3(0 07K)
    > at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    FileFormatEnum fmt)
    > at C1.Web.C1WebReport.X.4O(Boolean RI)
    > at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > at

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    I understand there's a problem. As I said, it is a bug in .NET 1.0.

    The main points are:

    1) We have an interim solution that works for .NET 1.0 (Environment.Exit(),
    make sure you don't have any #if DEBUG in there, that might disable it).

    2) The 1.1 build of the components fixes this. If you don't like the
    workaround, then upgrading is the best solution.

    3) In a couple of weeks, we will have our managed pdf filter, and the whole
    problem will go away (both for .NET 1.0 and 1.1). Unfortunately, development
    still takes some time (even in .NET ).

    I'm sorry for the inconvenience, but it is a Microsoft bug, and there are
    two solutions available now. The complete fix will be available soon. This
    is the best I can do…

    "Lee Melligner" wrote in message
    news:3ef85b68$1@news.componentone.com…
    >
    > Bernardo, I just checked my Global.asax file. I apparently left the
    Environment.Exit(0) statement in the code. That means that we're still
    getting the problem even with Environment.Exit(0); in the Global.asax.
    >
    > Lee
    >
    > "Bernardo de Castilho" wrote:
    > >It does work.
    > >
    > >The problem occurs if you make changes to the app, then rebuild it
    without
    > >restarting asnet_wp.exe.
    > >
    > >We have published a simple workaround that takes care of the problem,
    just
    > >add the following code to the global.asax.cs file:
    > >
    > > protected void Application_End(Object sender, EventArgs e)
    > > {
    > > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > > // error while developing apps (aspnet_wp will restart
    > >automatically).
    > > //
    > > Environment.Exit(0);
    > > }
    > >
    > >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    > >workaround).
    > >
    > >We will eventually have a pdf filter written in managed code, and that
    will
    > >allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter
    is
    > >not ready yet (should take a few weeks still).
    > >
    > >
    > >
    > >
    > >"Lee Mellinger" wrote in message
    > >news:3ef74e0f$1@news.componentone.com…
    > >>
    > >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    > >production development. It requires us to switch to VS 2003 and upgrade
    all
    > >of our components. It is absolutely essential that Component One get
    > >ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    > >>
    > >> "Bernardo de Castilho" wrote:
    > >> >Hi Michael.
    > >> >
    > >> >It does seem related to the appdomain problem.
    > >> >
    > >> >If you don't want to use the workaround (restarting aspnet_wp.exe),
    then
    > >the
    > >> >solution would be for you to switch to .NET 1.1 (where they fixed that
    > >bug)
    > >> >and wait for the 1.1 build of the component (we're testing it now, let
    me
    > >> >know if you would like a copy to test yourself).
    > >> >
    > >> >
    > >> >
    > >> >
    > >> >"Michael" wrote in message
    > >> >news:3ef49334$1@news.componentone.com…
    > >> >>
    > >> >> Has anyone else ever seen this? Seems to appear only when exporting
    to
    > >> >PDF. So I'm thinking that maybe its related to the appdomain error
    that
    > >> >I've seen referenced on here. Restarting ASPNET resolved it.
    > >> >>
    > >> >> ——Excerpt of stack trace below——
    > >> >> Exception has been thrown by the target of an invocation.
    > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    CultureInfo
    > >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    verifyAccess)
    > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    CultureInfo
    > >> >culture, Boolean verifyAccess)
    > >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    > >BindingFlags
    > >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    > >> >> at C1.Win.C1Report.2.1D()
    > >> >> at C1.Win.C1Report.Layout.9Q()
    > >> >> at C1.Win.C1Report.C1Report.B4()
    > >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > >> >FileFormatEnum fmt)
    > >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > >> >> at
    > >> >
    > >> >
    > >>
    > >
    > >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo, resetting the asp.net environment on a production server is not a viable solution. There could be hundreds of users on the system. This would bring performance to its knees. How does Crystal do this? They have PDFs working in 1.0…?

    "Bernardo de Castilho" wrote:
    >It does work.
    >
    >The problem occurs if you make changes to the app, then rebuild it without
    >restarting asnet_wp.exe.
    >
    >We have published a simple workaround that takes care of the problem, just
    >add the following code to the global.asax.cs file:
    >
    > protected void Application_End(Object sender, EventArgs e)
    > {
    > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > // error while developing apps (aspnet_wp will restart
    >automatically).
    > //
    > Environment.Exit(0);
    > }
    >
    >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    >workaround).
    >
    >We will eventually have a pdf filter written in managed code, and that will
    >allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter is
    >not ready yet (should take a few weeks still).
    >
    >
    >
    >
    >"Lee Mellinger" wrote in message
    >news:3ef74e0f$1@news.componentone.com…
    >>
    >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    >production development. It requires us to switch to VS 2003 and upgrade all
    >of our components. It is absolutely essential that Component One get
    >ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    >>
    >> "Bernardo de Castilho" wrote:
    >> >Hi Michael.
    >> >
    >> >It does seem related to the appdomain problem.
    >> >
    >> >If you don't want to use the workaround (restarting aspnet_wp.exe), then
    >the
    >> >solution would be for you to switch to .NET 1.1 (where they fixed that
    >bug)
    >> >and wait for the 1.1 build of the component (we're testing it now, let me
    >> >know if you would like a copy to test yourself).
    >> >
    >> >
    >> >
    >> >
    >> >"Michael" wrote in message
    >> >news:3ef49334$1@news.componentone.com…
    >> >>
    >> >> Has anyone else ever seen this? Seems to appear only when exporting to
    >> >PDF. So I'm thinking that maybe its related to the appdomain error that
    >> >I've seen referenced on here. Restarting ASPNET resolved it.
    >> >>
    >> >> ——Excerpt of stack trace below——
    >> >> Exception has been thrown by the target of an invocation.
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    >BindingFlags
    >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    >> >> at C1.Win.C1Report.2.1D()
    >> >> at C1.Win.C1Report.Layout.9Q()
    >> >> at C1.Win.C1Report.C1Report.B4()
    >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    >> >FileFormatEnum fmt)
    >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    >> >> at
    >> >
    >> >
    >>
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo, the solution you indicated below is only for development environments:

    "End aspnet_wp process to avoid possible UnloadedAppDomain
    error while developing apps"

    We need a REAL solution for production and deployment…

    Thanks!

    "Bernardo de Castilho" wrote:
    >It does work.
    >
    >The problem occurs if you make changes to the app, then rebuild it without
    >restarting asnet_wp.exe.
    >
    >We have published a simple workaround that takes care of the problem, just
    >add the following code to the global.asax.cs file:
    >
    > protected void Application_End(Object sender, EventArgs e)
    > {
    > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > // error while developing apps (aspnet_wp will restart
    >automatically).
    > //
    > Environment.Exit(0);
    > }
    >
    >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    >workaround).
    >
    >We will eventually have a pdf filter written in managed code, and that will
    >allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter is
    >not ready yet (should take a few weeks still).
    >
    >
    >
    >
    >"Lee Mellinger" wrote in message
    >news:3ef74e0f$1@news.componentone.com…
    >>
    >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    >production development. It requires us to switch to VS 2003 and upgrade all
    >of our components. It is absolutely essential that Component One get
    >ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    >>
    >> "Bernardo de Castilho" wrote:
    >> >Hi Michael.
    >> >
    >> >It does seem related to the appdomain problem.
    >> >
    >> >If you don't want to use the workaround (restarting aspnet_wp.exe), then
    >the
    >> >solution would be for you to switch to .NET 1.1 (where they fixed that
    >bug)
    >> >and wait for the 1.1 build of the component (we're testing it now, let me
    >> >know if you would like a copy to test yourself).
    >> >
    >> >
    >> >
    >> >
    >> >"Michael" wrote in message
    >> >news:3ef49334$1@news.componentone.com…
    >> >>
    >> >> Has anyone else ever seen this? Seems to appear only when exporting to
    >> >PDF. So I'm thinking that maybe its related to the appdomain error that
    >> >I've seen referenced on here. Restarting ASPNET resolved it.
    >> >>
    >> >> ——Excerpt of stack trace below——
    >> >> Exception has been thrown by the target of an invocation.
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    >BindingFlags
    >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    >> >> at C1.Win.C1Report.2.1D()
    >> >> at C1.Win.C1Report.Layout.9Q()
    >> >> at C1.Win.C1Report.C1Report.B4()
    >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    >> >FileFormatEnum fmt)
    >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    >> >> at
    >> >
    >> >
    >>
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo, I just checked my Global.asax file. I apparently left the Environment.Exit(0) statement in the code. That means that we're still getting the problem even with Environment.Exit(0); in the Global.asax.

    Lee

    "Bernardo de Castilho" wrote:
    >It does work.
    >
    >The problem occurs if you make changes to the app, then rebuild it without
    >restarting asnet_wp.exe.
    >
    >We have published a simple workaround that takes care of the problem, just
    >add the following code to the global.asax.cs file:
    >
    > protected void Application_End(Object sender, EventArgs e)
    > {
    > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > // error while developing apps (aspnet_wp will restart
    >automatically).
    > //
    > Environment.Exit(0);
    > }
    >
    >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    >workaround).
    >
    >We will eventually have a pdf filter written in managed code, and that will
    >allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter is
    >not ready yet (should take a few weeks still).
    >
    >
    >
    >
    >"Lee Mellinger" wrote in message
    >news:3ef74e0f$1@news.componentone.com…
    >>
    >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    >production development. It requires us to switch to VS 2003 and upgrade all
    >of our components. It is absolutely essential that Component One get
    >ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    >>
    >> "Bernardo de Castilho" wrote:
    >> >Hi Michael.
    >> >
    >> >It does seem related to the appdomain problem.
    >> >
    >> >If you don't want to use the workaround (restarting aspnet_wp.exe), then
    >the
    >> >solution would be for you to switch to .NET 1.1 (where they fixed that
    >bug)
    >> >and wait for the 1.1 build of the component (we're testing it now, let me
    >> >know if you would like a copy to test yourself).
    >> >
    >> >
    >> >
    >> >
    >> >"Michael" wrote in message
    >> >news:3ef49334$1@news.componentone.com…
    >> >>
    >> >> Has anyone else ever seen this? Seems to appear only when exporting to
    >> >PDF. So I'm thinking that maybe its related to the appdomain error that
    >> >I've seen referenced on here. Restarting ASPNET resolved it.
    >> >>
    >> >> ——Excerpt of stack trace below——
    >> >> Exception has been thrown by the target of an invocation.
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo
    >> >culture, Boolean verifyAccess)
    >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    >BindingFlags
    >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    >> >> at C1.Win.C1Report.2.1D()
    >> >> at C1.Win.C1Report.Layout.9Q()
    >> >> at C1.Win.C1Report.C1Report.B4()
    >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    >> >FileFormatEnum fmt)
    >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    >> >> at
    >> >
    >> >
    >>
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo,

    Just FYI, it isn't fixed in 1.1. I'm trying like heck to get an app working
    in 1.1, and I am continually getting the same error when trying to export to
    PDF: "Exception has been thrown by the target of an invocation"

    "Bernardo de Castilho" wrote in message
    news:3ef8cefd@news.componentone.com…
    > I understand there's a problem. As I said, it is a bug in .NET 1.0.
    >
    > The main points are:
    >
    > 1) We have an interim solution that works for .NET 1.0
    (Environment.Exit(),
    > make sure you don't have any #if DEBUG in there, that might disable it).
    >
    > 2) The 1.1 build of the components fixes this. If you don't like the
    > workaround, then upgrading is the best solution.
    >
    > 3) In a couple of weeks, we will have our managed pdf filter, and the
    whole
    > problem will go away (both for .NET 1.0 and 1.1). Unfortunately,
    development
    > still takes some time (even in .NET ).
    >
    > I'm sorry for the inconvenience, but it is a Microsoft bug, and there are
    > two solutions available now. The complete fix will be available soon. This
    > is the best I can do…
    >
    >
    >
    >
    > "Lee Melligner" wrote in message
    > news:3ef85b68$1@news.componentone.com…
    > >
    > > Bernardo, I just checked my Global.asax file. I apparently left the
    > Environment.Exit(0) statement in the code. That means that we're still
    > getting the problem even with Environment.Exit(0); in the Global.asax.
    > >
    > > Lee
    > >
    > > "Bernardo de Castilho" wrote:
    > > >It does work.
    > > >
    > > >The problem occurs if you make changes to the app, then rebuild it
    > without
    > > >restarting asnet_wp.exe.
    > > >
    > > >We have published a simple workaround that takes care of the problem,
    > just
    > > >add the following code to the global.asax.cs file:
    > > >
    > > > protected void Application_End(Object sender, EventArgs e)
    > > > {
    > > > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > > > // error while developing apps (aspnet_wp will restart
    > > >automatically).
    > > > //
    > > > Environment.Exit(0);
    > > > }
    > > >
    > > >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    > > >workaround).
    > > >
    > > >We will eventually have a pdf filter written in managed code, and that
    > will
    > > >allow us to sidestep this problem in .NET 1.0. Unfortunately, that
    filter
    > is
    > > >not ready yet (should take a few weeks still).
    > > >
    > > >
    > > >
    > > >
    > > >"Lee Mellinger" wrote in message
    > > >news:3ef74e0f$1@news.componentone.com…
    > > >>
    > > >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    > > >production development. It requires us to switch to VS 2003 and
    upgrade
    > all
    > > >of our components. It is absolutely essential that Component One get
    > > >ShowPDF() working in the 1.0 environment. Crystal seems to have done
    it!
    > > >>
    > > >> "Bernardo de Castilho" wrote:
    > > >> >Hi Michael.
    > > >> >
    > > >> >It does seem related to the appdomain problem.
    > > >> >
    > > >> >If you don't want to use the workaround (restarting aspnet_wp.exe),
    > then
    > > >the
    > > >> >solution would be for you to switch to .NET 1.1 (where they fixed
    that
    > > >bug)
    > > >> >and wait for the 1.1 build of the component (we're testing it now,
    let
    > me
    > > >> >know if you would like a copy to test yourself).
    > > >> >
    > > >> >
    > > >> >
    > > >> >
    > > >> >"Michael" wrote in message
    > > >> >news:3ef49334$1@news.componentone.com…
    > > >> >>
    > > >> >> Has anyone else ever seen this? Seems to appear only when
    exporting
    > to
    > > >> >PDF. So I'm thinking that maybe its related to the appdomain error
    > that
    > > >> >I've seen referenced on here. Restarting ASPNET resolved it.
    > > >> >>
    > > >> >> ——Excerpt of stack trace below——
    > > >> >> Exception has been thrown by the target of an invocation.
    > > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    obj,
    > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > CultureInfo
    > > >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    > verifyAccess)
    > > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    obj,
    > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > CultureInfo
    > > >> >culture, Boolean verifyAccess)
    > > >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    > > >BindingFlags
    > > >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    > > >> >> at C1.Win.C1Report.2.1D()
    > > >> >> at C1.Win.C1Report.Layout.9Q()
    > > >> >> at C1.Win.C1Report.C1Report.B4()
    > > >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > > >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > > >> >FileFormatEnum fmt)
    > > >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > > >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > > >> >> at
    > > >> >
    > > >> >
    > > >>
    > > >
    > > >
    > >
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Bernardo, just to verify, the new managed pdf filter will work in BOTH 1.0 and 1.1?

    Thanks,
    Lee

    "Bernardo de Castilho" wrote:
    >I understand there's a problem. As I said, it is a bug in .NET 1.0.
    >
    >The main points are:
    >
    >1) We have an interim solution that works for .NET 1.0 (Environment.Exit(),
    >make sure you don't have any #if DEBUG in there, that might disable it).
    >
    >2) The 1.1 build of the components fixes this. If you don't like the
    >workaround, then upgrading is the best solution.
    >
    >3) In a couple of weeks, we will have our managed pdf filter, and the whole
    >problem will go away (both for .NET 1.0 and 1.1). Unfortunately, development
    >still takes some time (even in .NET ).
    >
    >I'm sorry for the inconvenience, but it is a Microsoft bug, and there are
    >two solutions available now. The complete fix will be available soon. This
    >is the best I can do…
    >
    >
    >
    >
    >"Lee Melligner" wrote in message
    >news:3ef85b68$1@news.componentone.com…
    >>
    >> Bernardo, I just checked my Global.asax file. I apparently left the
    >Environment.Exit(0) statement in the code. That means that we're still
    >getting the problem even with Environment.Exit(0); in the Global.asax.
    >>
    >> Lee
    >>
    >> "Bernardo de Castilho" wrote:
    >> >It does work.
    >> >
    >> >The problem occurs if you make changes to the app, then rebuild it
    >without
    >> >restarting asnet_wp.exe.
    >> >
    >> >We have published a simple workaround that takes care of the problem,
    >just
    >> >add the following code to the global.asax.cs file:
    >> >
    >> > protected void Application_End(Object sender, EventArgs e)
    >> > {
    >> > // End aspnet_wp process to avoid possible UnloadedAppDomain
    >> > // error while developing apps (aspnet_wp will restart
    >> >automatically).
    >> > //
    >> > Environment.Exit(0);
    >> > }
    >> >
    >> >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested the
    >> >workaround).
    >> >
    >> >We will eventually have a pdf filter written in managed code, and that
    >will
    >> >allow us to sidestep this problem in .NET 1.0. Unfortunately, that filter
    >is
    >> >not ready yet (should take a few weeks still).
    >> >
    >> >
    >> >
    >> >
    >> >"Lee Mellinger" wrote in message
    >> >news:3ef74e0f$1@news.componentone.com…
    >> >>
    >> >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    >> >production development. It requires us to switch to VS 2003 and upgrade
    >all
    >> >of our components. It is absolutely essential that Component One get
    >> >ShowPDF() working in the 1.0 environment. Crystal seems to have done it!
    >> >>
    >> >> "Bernardo de Castilho" wrote:
    >> >> >Hi Michael.
    >> >> >
    >> >> >It does seem related to the appdomain problem.
    >> >> >
    >> >> >If you don't want to use the workaround (restarting aspnet_wp.exe),
    >then
    >> >the
    >> >> >solution would be for you to switch to .NET 1.1 (where they fixed that
    >> >bug)
    >> >> >and wait for the 1.1 build of the component (we're testing it now, let
    >me
    >> >> >know if you would like a copy to test yourself).
    >> >> >
    >> >> >
    >> >> >
    >> >> >
    >> >> >"Michael" wrote in message
    >> >> >news:3ef49334$1@news.componentone.com…
    >> >> >>
    >> >> >> Has anyone else ever seen this? Seems to appear only when exporting
    >to
    >> >> >PDF. So I'm thinking that maybe its related to the appdomain error
    >that
    >> >> >I've seen referenced on here. Restarting ASPNET resolved it.
    >> >> >>
    >> >> >> ——Excerpt of stack trace below——
    >> >> >> Exception has been thrown by the target of an invocation.
    >> >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    >CultureInfo
    >> >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    >verifyAccess)
    >> >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj,
    >> >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    >CultureInfo
    >> >> >culture, Boolean verifyAccess)
    >> >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    >> >BindingFlags
    >> >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    >> >> >> at C1.Win.C1Report.2.1D()
    >> >> >> at C1.Win.C1Report.Layout.9Q()
    >> >> >> at C1.Win.C1Report.C1Report.B4()
    >> >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    >> >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    >> >> >FileFormatEnum fmt)
    >> >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    >> >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    >> >> >> at
    >> >> >
    >> >> >
    >> >>
    >> >
    >> >
    >>
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Yes, I believe it will.

    The 1.0 bug is related to .NET unloading unmanaged assemblies. Once the
    filter becomes managed, all should be fine.

    "Lee Melligner" wrote in message
    news:3ef98ea3$1@news.componentone.com…
    >
    > Bernardo, just to verify, the new managed pdf filter will work in BOTH 1.0
    and 1.1?
    >
    > Thanks,
    > Lee
    >
    > "Bernardo de Castilho" wrote:
    > >I understand there's a problem. As I said, it is a bug in .NET 1.0.
    > >
    > >The main points are:
    > >
    > >1) We have an interim solution that works for .NET 1.0
    (Environment.Exit(),
    > >make sure you don't have any #if DEBUG in there, that might disable it).
    > >
    > >2) The 1.1 build of the components fixes this. If you don't like the
    > >workaround, then upgrading is the best solution.
    > >
    > >3) In a couple of weeks, we will have our managed pdf filter, and the
    whole
    > >problem will go away (both for .NET 1.0 and 1.1). Unfortunately,
    development
    > >still takes some time (even in .NET ).
    > >
    > >I'm sorry for the inconvenience, but it is a Microsoft bug, and there are
    > >two solutions available now. The complete fix will be available soon.
    This
    > >is the best I can do…
    > >
    > >
    > >
    > >
    > >"Lee Melligner" wrote in message
    > >news:3ef85b68$1@news.componentone.com…
    > >>
    > >> Bernardo, I just checked my Global.asax file. I apparently left the
    > >Environment.Exit(0) statement in the code. That means that we're still
    > >getting the problem even with Environment.Exit(0); in the Global.asax.
    > >>
    > >> Lee
    > >>
    > >> "Bernardo de Castilho" wrote:
    > >> >It does work.
    > >> >
    > >> >The problem occurs if you make changes to the app, then rebuild it
    > >without
    > >> >restarting asnet_wp.exe.
    > >> >
    > >> >We have published a simple workaround that takes care of the problem,
    > >just
    > >> >add the following code to the global.asax.cs file:
    > >> >
    > >> > protected void Application_End(Object sender, EventArgs e)
    > >> > {
    > >> > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > >> > // error while developing apps (aspnet_wp will restart
    > >> >automatically).
    > >> > //
    > >> > Environment.Exit(0);
    > >> > }
    > >> >
    > >> >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested
    the
    > >> >workaround).
    > >> >
    > >> >We will eventually have a pdf filter written in managed code, and that
    > >will
    > >> >allow us to sidestep this problem in .NET 1.0. Unfortunately, that
    filter
    > >is
    > >> >not ready yet (should take a few weeks still).
    > >> >
    > >> >
    > >> >
    > >> >
    > >> >"Lee Mellinger" wrote in message
    > >> >news:3ef74e0f$1@news.componentone.com…
    > >> >>
    > >> >> Bernardo, switching to 1.1 is a major undertaking for those of us in
    > >> >production development. It requires us to switch to VS 2003 and
    upgrade
    > >all
    > >> >of our components. It is absolutely essential that Component One get
    > >> >ShowPDF() working in the 1.0 environment. Crystal seems to have done
    it!
    > >> >>
    > >> >> "Bernardo de Castilho" wrote:
    > >> >> >Hi Michael.
    > >> >> >
    > >> >> >It does seem related to the appdomain problem.
    > >> >> >
    > >> >> >If you don't want to use the workaround (restarting aspnet_wp.exe),
    > >then
    > >> >the
    > >> >> >solution would be for you to switch to .NET 1.1 (where they fixed
    that
    > >> >bug)
    > >> >> >and wait for the 1.1 build of the component (we're testing it now,
    let
    > >me
    > >> >> >know if you would like a copy to test yourself).
    > >> >> >
    > >> >> >
    > >> >> >
    > >> >> >
    > >> >> >"Michael" wrote in message
    > >> >> >news:3ef49334$1@news.componentone.com…
    > >> >> >>
    > >> >> >> Has anyone else ever seen this? Seems to appear only when
    exporting
    > >to
    > >> >> >PDF. So I'm thinking that maybe its related to the appdomain error
    > >that
    > >> >> >I've seen referenced on here. Restarting ASPNET resolved it.
    > >> >> >>
    > >> >> >> ——Excerpt of stack trace below——
    > >> >> >> Exception has been thrown by the target of an invocation.
    > >> >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    obj,
    > >> >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > >CultureInfo
    > >> >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    > >verifyAccess)
    > >> >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    obj,
    > >> >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > >CultureInfo
    > >> >> >culture, Boolean verifyAccess)
    > >> >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    > >> >BindingFlags
    > >> >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo
    culture)
    > >> >> >> at C1.Win.C1Report.2.1D()
    > >> >> >> at C1.Win.C1Report.Layout.9Q()
    > >> >> >> at C1.Win.C1Report.C1Report.B4()
    > >> >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > >> >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > >> >> >FileFormatEnum fmt)
    > >> >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > >> >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > >> >> >> at
    > >> >> >
    > >> >> >
    > >> >>
    > >> >
    > >> >
    > >>
    > >
    > >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Please make sure you have the most recent version of the C1PrintUtil.dll
    (the 1.1 build) in the GAC. It could be picking up the wrong one.

    If you can't figure it out, please send a stack trace. Thanks.

    "Charles Richardson" wrote in message
    news:3efa27de$1@news.componentone.com…
    > Bernardo,
    >
    > Just FYI, it isn't fixed in 1.1. I'm trying like heck to get an app
    working
    > in 1.1, and I am continually getting the same error when trying to export
    to
    > PDF: "Exception has been thrown by the target of an invocation"
    >
    >
    > "Bernardo de Castilho" wrote in message
    > news:3ef8cefd@news.componentone.com…
    > > I understand there's a problem. As I said, it is a bug in .NET 1.0.
    > >
    > > The main points are:
    > >
    > > 1) We have an interim solution that works for .NET 1.0
    > (Environment.Exit(),
    > > make sure you don't have any #if DEBUG in there, that might disable it).
    > >
    > > 2) The 1.1 build of the components fixes this. If you don't like the
    > > workaround, then upgrading is the best solution.
    > >
    > > 3) In a couple of weeks, we will have our managed pdf filter, and the
    > whole
    > > problem will go away (both for .NET 1.0 and 1.1). Unfortunately,
    > development
    > > still takes some time (even in .NET ).
    > >
    > > I'm sorry for the inconvenience, but it is a Microsoft bug, and there
    are
    > > two solutions available now. The complete fix will be available soon.
    This
    > > is the best I can do…
    > >
    > >
    > >
    > >
    > > "Lee Melligner" wrote in message
    > > news:3ef85b68$1@news.componentone.com…
    > > >
    > > > Bernardo, I just checked my Global.asax file. I apparently left the
    > > Environment.Exit(0) statement in the code. That means that we're still
    > > getting the problem even with Environment.Exit(0); in the Global.asax.
    > > >
    > > > Lee
    > > >
    > > > "Bernardo de Castilho" wrote:
    > > > >It does work.
    > > > >
    > > > >The problem occurs if you make changes to the app, then rebuild it
    > > without
    > > > >restarting asnet_wp.exe.
    > > > >
    > > > >We have published a simple workaround that takes care of the problem,
    > > just
    > > > >add the following code to the global.asax.cs file:
    > > > >
    > > > > protected void Application_End(Object sender, EventArgs e)
    > > > > {
    > > > > // End aspnet_wp process to avoid possible UnloadedAppDomain
    > > > > // error while developing apps (aspnet_wp will restart
    > > > >automatically).
    > > > > //
    > > > > Environment.Exit(0);
    > > > > }
    > > > >
    > > > >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested
    the
    > > > >workaround).
    > > > >
    > > > >We will eventually have a pdf filter written in managed code, and
    that
    > > will
    > > > >allow us to sidestep this problem in .NET 1.0. Unfortunately, that
    > filter
    > > is
    > > > >not ready yet (should take a few weeks still).
    > > > >
    > > > >
    > > > >
    > > > >
    > > > >"Lee Mellinger" wrote in message
    > > > >news:3ef74e0f$1@news.componentone.com…
    > > > >>
    > > > >> Bernardo, switching to 1.1 is a major undertaking for those of us
    in
    > > > >production development. It requires us to switch to VS 2003 and
    > upgrade
    > > all
    > > > >of our components. It is absolutely essential that Component One get
    > > > >ShowPDF() working in the 1.0 environment. Crystal seems to have done
    > it!
    > > > >>
    > > > >> "Bernardo de Castilho" wrote:
    > > > >> >Hi Michael.
    > > > >> >
    > > > >> >It does seem related to the appdomain problem.
    > > > >> >
    > > > >> >If you don't want to use the workaround (restarting
    aspnet_wp.exe),
    > > then
    > > > >the
    > > > >> >solution would be for you to switch to .NET 1.1 (where they fixed
    > that
    > > > >bug)
    > > > >> >and wait for the 1.1 build of the component (we're testing it now,
    > let
    > > me
    > > > >> >know if you would like a copy to test yourself).
    > > > >> >
    > > > >> >
    > > > >> >
    > > > >> >
    > > > >> >"Michael" wrote in message
    > > > >> >news:3ef49334$1@news.componentone.com…
    > > > >> >>
    > > > >> >> Has anyone else ever seen this? Seems to appear only when
    > exporting
    > > to
    > > > >> >PDF. So I'm thinking that maybe its related to the appdomain
    error
    > > that
    > > > >> >I've seen referenced on here. Restarting ASPNET resolved it.
    > > > >> >>
    > > > >> >> ——Excerpt of stack trace below——
    > > > >> >> Exception has been thrown by the target of an invocation.
    > > > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    > obj,
    > > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > > CultureInfo
    > > > >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    > > verifyAccess)
    > > > >> >> at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    > obj,
    > > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > > CultureInfo
    > > > >> >culture, Boolean verifyAccess)
    > > > >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    > > > >BindingFlags
    > > > >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo
    culture)
    > > > >> >> at C1.Win.C1Report.2.1D()
    > > > >> >> at C1.Win.C1Report.Layout.9Q()
    > > > >> >> at C1.Win.C1Report.C1Report.B4()
    > > > >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > > > >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > > > >> >FileFormatEnum fmt)
    > > > >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > > > >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean embedFonts)
    > > > >> >> at
    > > > >> >
    > > > >> >
    > > > >>
    > > > >
    > > > >
    > > >
    > >
    > >
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    My mistake. It is working fine. I forgot to stop the ASP_NET process after
    recompiling. As long as I do that, all works well. And I can make changes to
    the xml file with the report definitions without stopping the process.

    "Bernardo de Castilho" wrote in message
    news:3efb8b12@news.componentone.com…
    > Please make sure you have the most recent version of the C1PrintUtil.dll
    > (the 1.1 build) in the GAC. It could be picking up the wrong one.
    >
    > If you can't figure it out, please send a stack trace. Thanks.
    >
    >
    > "Charles Richardson" wrote in message
    > news:3efa27de$1@news.componentone.com…
    > > Bernardo,
    > >
    > > Just FYI, it isn't fixed in 1.1. I'm trying like heck to get an app
    > working
    > > in 1.1, and I am continually getting the same error when trying to
    export
    > to
    > > PDF: "Exception has been thrown by the target of an invocation"
    > >
    > >
    > > "Bernardo de Castilho" wrote in message
    > > news:3ef8cefd@news.componentone.com…
    > > > I understand there's a problem. As I said, it is a bug in .NET 1.0.
    > > >
    > > > The main points are:
    > > >
    > > > 1) We have an interim solution that works for .NET 1.0
    > > (Environment.Exit(),
    > > > make sure you don't have any #if DEBUG in there, that might disable
    it).
    > > >
    > > > 2) The 1.1 build of the components fixes this. If you don't like the
    > > > workaround, then upgrading is the best solution.
    > > >
    > > > 3) In a couple of weeks, we will have our managed pdf filter, and the
    > > whole
    > > > problem will go away (both for .NET 1.0 and 1.1). Unfortunately,
    > > development
    > > > still takes some time (even in .NET ).
    > > >
    > > > I'm sorry for the inconvenience, but it is a Microsoft bug, and there
    > are
    > > > two solutions available now. The complete fix will be available soon.
    > This
    > > > is the best I can do…
    > > >
    > > >
    > > >
    > > >
    > > > "Lee Melligner" wrote in message
    > > > news:3ef85b68$1@news.componentone.com…
    > > > >
    > > > > Bernardo, I just checked my Global.asax file. I apparently left the
    > > > Environment.Exit(0) statement in the code. That means that we're
    still
    > > > getting the problem even with Environment.Exit(0); in the Global.asax.
    > > > >
    > > > > Lee
    > > > >
    > > > > "Bernardo de Castilho" wrote:
    > > > > >It does work.
    > > > > >
    > > > > >The problem occurs if you make changes to the app, then rebuild it
    > > > without
    > > > > >restarting asnet_wp.exe.
    > > > > >
    > > > > >We have published a simple workaround that takes care of the
    problem,
    > > > just
    > > > > >add the following code to the global.asax.cs file:
    > > > > >
    > > > > > protected void Application_End(Object sender, EventArgs e)
    > > > > > {
    > > > > > // End aspnet_wp process to avoid possible
    UnloadedAppDomain
    > > > > > // error while developing apps (aspnet_wp will restart
    > > > > >automatically).
    > > > > > //
    > > > > > Environment.Exit(0);
    > > > > > }
    > > > > >
    > > > > >This is a Microsoft bug, they fixed in .NET 1.1 (and also suggested
    > the
    > > > > >workaround).
    > > > > >
    > > > > >We will eventually have a pdf filter written in managed code, and
    > that
    > > > will
    > > > > >allow us to sidestep this problem in .NET 1.0. Unfortunately, that
    > > filter
    > > > is
    > > > > >not ready yet (should take a few weeks still).
    > > > > >
    > > > > >
    > > > > >
    > > > > >
    > > > > >"Lee Mellinger" wrote in message
    > > > > >news:3ef74e0f$1@news.componentone.com…
    > > > > >>
    > > > > >> Bernardo, switching to 1.1 is a major undertaking for those of us
    > in
    > > > > >production development. It requires us to switch to VS 2003 and
    > > upgrade
    > > > all
    > > > > >of our components. It is absolutely essential that Component One
    get
    > > > > >ShowPDF() working in the 1.0 environment. Crystal seems to have
    done
    > > it!
    > > > > >>
    > > > > >> "Bernardo de Castilho" wrote:
    > > > > >> >Hi Michael.
    > > > > >> >
    > > > > >> >It does seem related to the appdomain problem.
    > > > > >> >
    > > > > >> >If you don't want to use the workaround (restarting
    > aspnet_wp.exe),
    > > > then
    > > > > >the
    > > > > >> >solution would be for you to switch to .NET 1.1 (where they
    fixed
    > > that
    > > > > >bug)
    > > > > >> >and wait for the 1.1 build of the component (we're testing it
    now,
    > > let
    > > > me
    > > > > >> >know if you would like a copy to test yourself).
    > > > > >> >
    > > > > >> >
    > > > > >> >
    > > > > >> >
    > > > > >> >"Michael" wrote in message
    > > > > >> >news:3ef49334$1@news.componentone.com…
    > > > > >> >>
    > > > > >> >> Has anyone else ever seen this? Seems to appear only when
    > > exporting
    > > > to
    > > > > >> >PDF. So I'm thinking that maybe its related to the appdomain
    > error
    > > > that
    > > > > >> >I've seen referenced on here. Restarting ASPNET resolved it.
    > > > > >> >>
    > > > > >> >> ——Excerpt of stack trace below——
    > > > > >> >> Exception has been thrown by the target of an invocation.
    > > > > >> >> at
    System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    > > obj,
    > > > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > > > CultureInfo
    > > > > >> >culture, Boolean isBinderDefault, Assembly caller, Boolean
    > > > verifyAccess)
    > > > > >> >> at
    System.Reflection.RuntimeMethodInfo.InternalInvoke(Object
    > > obj,
    > > > > >> >BindingFlags invokeAttr, Binder binder, Object[] parameters,
    > > > CultureInfo
    > > > > >> >culture, Boolean verifyAccess)
    > > > > >> >> at System.Reflection.RuntimeMethodInfo.Invoke(Object obj,
    > > > > >BindingFlags
    > > > > >> >invokeAttr, Binder binder, Object[] parameters, CultureInfo
    > culture)
    > > > > >> >> at C1.Win.C1Report.2.1D()
    > > > > >> >> at C1.Win.C1Report.Layout.9Q()
    > > > > >> >> at C1.Win.C1Report.C1Report.B4()
    > > > > >> >> at C1.Win.C1Report.C1Report.B3(0 07K)
    > > > > >> >> at C1.Win.C1Report.C1Report.RenderToFile(String fileName,
    > > > > >> >FileFormatEnum fmt)
    > > > > >> >> at C1.Web.C1WebReport.X.4O(Boolean RI)
    > > > > >> >> at C1.Web.C1WebReport.C1WebReport.ShowPDF(Boolean
    embedFonts)
    > > > > >> >> at
    > > > > >> >
    > > > > >> >
    > > > > >>
    > > > > >
    > > > > >
    > > > >
    > > >
    > > >
    > >
    > >
    >
    >

  • 2p
    newsgroup_archive2p 11 years, 5 months ago

    Hi there. I was having the same problem with ShowPDF and have upgraded to Framework 1.1, as well as Visual Studio 2003. I am now getting the error: "Thie directory is invalid" on the call to ShowPDF. Any suggestions?

    Thanks!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.